Connectivity problems to certain lxc container


I’ve got this weird problem when trying to connect to a certain container from another container on the same subnet. I’m using proxmox 4.4-13. The debian packages are called lxc-pve 2.0.7-4 and lxcfs 2.0.6-pve1.

The first container, cannot connect to the second lxc container by any means except ping. Both container run Ubuntu 16.0.4 LTS.
I can ssh to .211 even outside of the network (from my own pc, for instance), but I can’t do it from .207, and neither can I do it using another container on the same server and on the same subnet. Internet works on both. And both have two network cards, one using the privates IPs I’ve just mentioned, the other using public IPs. The private IPs are on a linux bridge configured on the host level.

Of course, I also tried using the public IPs, but the behaviour is identical. And I also tried other ports from .207 such as 80, 8888 (which, obviously, are open on the .211 container), etc. but it doesn’t work. I still can’t understand why ping does work, whereas all other type of traffic doesn’t.

Moreoever, I can connect through ssh, http, etc. from .211 to .207 (but not the other way around, as I’ve already mentioned). So the other way around works! I’m really buffled. Any help would be greatly appreciated. Even some clues as to where I should look. Tcpdump for ssh on both the host and the .211 container show one-way packages from .207 to .211, but no reply from .211 to .207.


Sorry. It was actually a firewall problem. I hadn’t paid attention. Silly me :slight_smile: Thanks anyway.