Container not running - After reinstalling LXD


(HSB) #1

When I run following commands, all components are created fine. But when I create container, Network is not attached to it and is in STOPPED state (hangs up).

What I may be missing in the process? This process somehow worked fine before.

It works fine when I run: sudo lxd init (I compared contents using show command)

Ubuntu: 18.04.2 LTS
LXD Version: 3.0.3

LXC  commands;
    lxc profile create test
    lxc network create testbr0
    lxc network attach-profile testbr0 test eth0 eth0
    lxc storage create test lvm size=200GB
    lxc profile device add test root disk path=/ pool=test size=20GB

LXC  command response:
    Profile test created
    Network testbr0 created
    Storage pool test created
    Device root added to test

Container creation command:
   lxc launch ubuntu:bionic/amd64 testc -p test

#2

Hi!

When you run sudo lxd init, it creates a default profile for you called default. It’s a hard-coded name.
You can view this profile with lxc profile show default.

You can replicate this default profile in a similar way that you do above. If the new profile does not work as expected, you can always compare to the default one (or whichever is working).
Run lxc profile show test and compare to the default profile.

Note that sudo lxd init is a wizard. You could run a set of lxc commands to setup LXD manually.


#3

Network problem in all containers -> always check if dnsmasq is running in the host


(HSB) #4

@simos and @gpatel-fr - Thanks for your thoughts.
After spending some time, I figured that issue was with LXD service. Once restarted, and network was up and running.