Containers network problem on same bridge

Hi all, i have strange issue with networking and will be thankful if some one can point me to right direction to solve it.

LXD version 4.2
OS: OpenSUSE Tumbleweed with kernel 4.7.5
Networking with NetworkManager

Im running NGINX server in one container and in second container i want to get file from the NGINX by wget but connection hang, i get only first 27kB of file. Files smaller that 1.5kB are transfered correctly.

The same wget work when i run it from other hosts on network.

Two containers are on the same bridge and network on one host and:

  • bridge is stantard br created manualy not by LXD
  • firewalling is disabled
  • no rouitng or nat on network
  • ping between containers work but only to size 1476 bytes
  • containers are also visible for other host on network

Any ideas ?


The 1476 max size suggests an MTU of 1500.

1500 bytes (Ethernet mtu) - 20 byte (IP header) - 8 byte (ICMP header) 
= 1472 byte

Have you tried using other applications to transfer the file, such as scp? To rule out an application specific issue.

When i summarized this problem im found root cause… its wrong configuration of MTU.

VETH* interface of container on LXD host have 1500 but inside container network interface have 9000 which i set by mistake inside container for net device.

Thank you :slight_smile:

1 Like