Failed to join node to network in GCP, missing lxdfan0 in project default

I’m trying to join a second node to a cluster in a new project. However, when I try and lxd init it into the cluster, I get this message and it fails: “Error: Failed to join cluster: Failed request to add member: Missing network “lxdfan0” in project “default””

I’m not sure what may be causing this as, to my knowledge, all necessary ports and such are open between the hosts. Nothing useful is showing up in the logs and the “verbose” option to the init command, isn’t verbose. It doesn’t say anything more than the non-verbose.

Anyone have thoughts on where I can look next?

You’ll want to look at lxd.log on the joining server, it sounds like it may have failed to create/start for some reason?

In /var/snap/lxd/common/lxd/logs/lxd.log? Unfortunately, nothing is logged. Not nothing useful, nothing at all after the last time lxd itself was started

Odd. Are you running the exact same LXD version on both systems?
Can you also show lxc network show lxdfan0 on the initial system?

So, in a case of “surprise!”, no, they weren’t the same version. Not entirely certain how that happened, as these are all brand new VMs, so I’ll just chuck it up to “Because GCP”. I snap removed and snap installed LXD and that seems to have cured the initial issue.

However, it did result in a new issue where the “lxd” command says this:

/snap/lxd/20750/commands/lxd: 18: SNAP_CURRENT: parameter not set
basename: missing operand
Try 'basename --help' for more information.

It did init correctly, so that’s good at least

Doh, that one is my bad, it broke as I was cleaning up some of our scripts earlier and somehow didn’t cause any test failures…

I’ve now pushed a fix which I hope to release to everyone in the next hour or so.

Whoops haha thought I had some more weirdness :smiley: