How can I disable shiftfs on a lxd installed from source

It seems that when installed from source shiftfs is true, while when installing from snap it is false.

How can I switch to false on an lxd installed from source? Since upgrading to 5.6 I’m having a “Value too large for defined data type” error when editing file inside a container on this installation, and I don’t have it in an installation done via snap, so this would be my first attempt in troubleshooting.

That error is a kernel bug, it’s tracked here Bug #1990849 “LXD containers using shiftfs on ZFS or TMPFS broke...” : Bugs : linux package : Ubuntu

You can set LXD_SHIFTFS_DISABLE=1 in your lxd daemon’s environment to disable shiftfs.

This is not actually a LXD 5.6 issue, but a kernel issue that arrived around the same time.

Hello,

Ok thanks for the feedback. I’ll disable shiftfs momentarily.

Is the environment variable method applicable in general for server-level configuration switch?

Yes this one is, see Environment variables - LXD documentation

Thanks!