How can I restore a container on a "new" machine?!

I had initial issues with my install of ubuntu 18 so i swapped out the os disk and rebuilt it.

my original LXD build was in a ZFS file partition on a different datapool so when i rebuilt the system i did a “zfs import DATA” and have access to my snapshots / etc

when I ran “lxd init” on my new machine I tried to give it the dataset where the pool currently existed - DATA/LXD

however it told me it couldn’t use that pool because it was not empty so i used a new location DATA/LXC

How can I restore my containers?

edit: attempting to follow this

i mounted my container

zfs mount DATA/LXD/containers/piholeunifi

which worked

SERVER:/var/lib/lxd/storage-pools/default/containers/piholeunifi$ sudo ls
total 49K
 11K drwx--x--x  4 165536 165536    6 Sep 30 10:05 .
 4.0K drwxr-xr-x  3 root   root   4.0K Oct 15 18:33 ..
 6.0K -r--------  1 root   root   2.4K Oct 15 05:18 backup.yaml
 6.0K -rw-r--r--  1 root   root   1.1K Sep 11 17:58 metadata.yaml
 11K drwxr-xr-x 22 165536 165536   22 Sep 11 16:59 rootfs
 11K drwxr-xr-x  2 root   root      7 Sep 11 17:58 templates

sudo lxd import piholeunifi
Error: The container "piholeunifi" does not seem to exist on any storage pool

|MODERATION: Removed spam links, considering to remove the whole thread|

You may create a new container with the same OS.
Then stop it and replace rootfs with the files from old container.