Incus service inexplicably "not found" after some short period of inactivity

Bare metal host is running Ubuntu 24.04 and I installed Incus using the Zabbly repo:

type root@labrat:/etc/apt/sources.list.d# cat zabbly-incus-lts-7.0.sources 
Enabled: yes
Types: deb
URIs: https://pkgs.zabbly.com/incus/lts-7.0
Suites: noble
Components: main
Architectures: amd64
Signed-By: /etc/apt/keyrings/zabbly.asc
apt install incus

At first everything seemed fine and I was able to run incus admin init (as myself, after adding myself to the incus-admin group).

However, after say an hour of inactivity

pgoetz@labrat ~$ incus launch images:ubuntu/24.04 web1
Error: The incus daemon doesn't appear to be started (socket path: /var/lib/incus/unix.socket)
root@labrat:/etc/apt/sources.list.d# systemctl status incus
● incus.service
     Loaded: not-found (Reason: Unit incus.service not found.)
     Active: active (running) since Wed 2026-08-12 15:52:48 CDT; 1h 19min ago
   Main PID: 1266000 (incusd)
        CPU: 1.958s
     CGroup: /system.slice/incus.service
             └─1266000 /usr/libexec/incus/incusd --group incus-admin --logfile=/var/log/incus/incus.log

Aug 12 15:52:47 labrat systemd[1]: Starting incus.service - Incus - Main daemon...
Aug 12 15:52:47 labrat incusd[1266000]: time="2026-08-12T15:52:47-05:00" level=warning msg="Instance type not operational" driver=qemu err="QEMU command not available for CPU architecture" type=virtual-machine
Aug 12 15:52:48 labrat systemd[1]: Started incus.service - Incus - Main daemon.
root@labrat:/etc/apt/sources.list.d# incus list
Error: The incus daemon doesn't appear to be started (socket path: /var/lib/incus/unix.socket)
root@labrat:/etc/apt/sources.list.d# systemctl restart incus
Failed to restart incus.service: Unit incus.service not found.
root@labrat:/etc/apt/sources.list.d# systemctl list-units | grep incus
  var-lib-incus-guestapi.mount                     loaded    active mounted   /var/lib/incus/guestapi
  var-lib-incus-shmounts.mount                     loaded    active mounted   /var/lib/incus/shmounts
● incus-startup.service                            not-found active exited    incus-startup.service
● incus.service                                    not-found active running   incus.service
● incus-user.socket                                not-found active listening incus-user.socket
● incus.socket                                     not-found active running   incus.socket

Meanwhile the service file absolutely exists in /usr/lib/systemd/system:

root@labrat:~# ls /usr/lib/systemd/system/incus*
/usr/lib/systemd/system/incus-agent.service

Not sure I’ve seen a problem like this before – does anyone have any idea what’s going on here?

Can you check what packages are installed at that stage? (dpkg -l | grep incus)

root@labrat:~# dpkg -l | grep incus
ii  incus-agent                                    6.0.0-1ubuntu0.3+esm3                            amd64        Incus guest agent
ii  incus-client                                   6.0.0-1ubuntu0.3+esm3                            amd64        Powerful system container and virtual machine manager - client

Yeah, so Incus isn’t installed on that machine anymore.
It also shows packages that aren’t from Zabbly but from the Ubuntu ESM repository instead.

You may want to look at Install Stable on 24.04 with Ubuntu Pro enabled - #2 by Lox

Argh. Thanks, Stéphane, I should have noticed this. I added the pinning thing in /etc/apt/preferences.d/incus as per the linked reference, but I think the actual problem (inexplicably) was the permissions on /etc/apt/keyrings/zabbly.asc. By default, these were 600, and when I ran apt update this time I noticed that

W: GPG error: https://pkgs.zabbly.com/incus/lts-7.0 noble InRelease: Unknown error executing apt-key
E: The repository 'https://pkgs.zabbly.com/incus/lts-7.0 noble InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.

Changing the permissions to 644 resolved this issue and subsequently running apt install incus installed the correct packages from Zabbly:

root@labrat:~# dpkg -l | grep incus
ii  incus              1:7.0.1-ubuntu24.04-202607310258   amd64        Incus - Container and virtualization daemon
ii  incus-base         1:7.0.1-ubuntu24.04-202607310258   amd64        Incus - Container and virtualization daemon (container-only)
ii  incus-client       1:7.0.1-ubuntu24.04-202607310258   amd64        Incus - Command line client

Since I now think I never had the correct packages installed and just didn’t notice the apt update errors, I’m going to mark this comment as the solution, but for anyone reading this, refer back to the previous comment if it turns out pinning the Zabbly repo is necessary.