Lxc cannot start with overlayfs

I created an lxc container with overlay option, but it cannot be started, the error:
lxc-start nc 20190701095142.638 ERROR start - start.c:start:2061 - No such device or address - Failed to exec “/sbin/init”
lxc-start nc 20190701095142.639 ERROR sync - sync.c:__sync_wait:62 - An error occurred in another process (expected sequence number 7)
lxc-start nc 20190701095142.639 ERROR lxccontainer - lxccontainer.c:wait_on_daemonized_start:864 - Received container state “ABORTING” instead of “RUNNING”
lxc-start nc 20190701095142.639 ERROR lxc_start - lxc_start.c:main:330 - The container failed to start
lxc-start nc 20190701095142.639 ERROR lxc_start - lxc_start.c:main:333 - To get more details, run the container in foreground mode
lxc-start nc 20190701095142.640 ERROR lxc_start - lxc_start.c:main:336 - Additional information can be obtained by setting the --logfile and --logpriority options
lxc-start nc 20190701095142.641 ERROR start - start.c:__lxc_start:1972 - Failed to spawn container “nc”
The container config is like this:
lxc.net.0.type = empty
lxc.rootfs.path = overlay:/var/lib/lxc/nc/rootfs:/var/lib/lxc/nc/delta0

I changed the rootfs path to /var/lib/lxc/nc/rootfs, it can start, but this config does not work, does any know about this? Thanks

I know to how to resolve this.
The rootfs of lxc will build in /var/…, however this directory in our system is ramfs and overlayfs system, so I change the rootfs to the persistent storage, and modify the config file to point to that directory, it works now. But I still dont know why lxc overlay cannot be in ramfs… anyway, it works now