Lxd container within lxd container

lxd

(Najib Nour) #1

Good Morning, i have been having this issue for a little while now. cannot find the solution, i am running ubuntu 18.04 container on my main host and then installing snaplxd on the container but have no tab auto complete, i didint think much of it but when i went ahead and launched a container(ubuntu 18.04) i could not get the container to start any ideas?


#2

You have two questions here,

  1. How do I enable nested container in LXD?
    The answer is that you need to enable nested container support in the specific container. See https://blog.ubuntu.com/2015/10/30/nested-containers-in-lxd on how to do that on a new container or how to reconfigure an existing container to accepted nested containers.

  2. How do I enable LXD Bash shell completion?
    It is already enabled for the Bash shell in /usr/share/bash-completion/completions/lxc and /usr/share/bash-completion/completions/lxd.lxc. When you launch a new container with Ubuntu 18.04, you get by default the deb package of LXD, and it comes with Bash completion for the lxc command.
    But what happens if you sudo apt remove --purge lxd lxd-client and install the snap package of LXD?
    The snap package installs the required Bash completion for LXD.

    ubuntu@complete:~$ ls -l /usr/share/bash-completion/completions/lxd.lxc 
    lrwxrwxrwx 1 root root 44 Nov  6 14:28 /usr/share/bash-completion/completions/lxd.lxc -> /snap/core/current/usr/lib/snapd/complete.sh
    ubuntu@complete:~$ 
    

    You need to start a fresh Bash shell if you just installed LXD. Or, run source /etc/bash_completion so that the current shell works as well.


(Najib Nour) #3

Thank you!! Very well explained !