LXD deb packaging effort

Just in case someone like me misses the good old debian package of LXD for current Ubuntu LTS, there is an ongoing effort to package up latest LXD releases (4.x) as debian packages instead of snap.

Feedback is highly appreciated.

2 Likes

Thanks for your efforts ! Do you plan to provide this package through a PPA repository ? Also, I checked quickly the dependencies, is it possible to add virtual machines dependencies ? (I suppose qemu, qemu-img and some others dependencies)

Adding qemu stuff as optional dependency is possible, I would like to avoid using this as recommended to install.

Another possibility is to make meta-package to install VM deps.

I will think about PPA.

1 Like