LXD for VM with Spice not working on Manjaro

When attempting to start a new vm with lxd on Manjaro (latest) using lxd 4.10, the following error occurs:

qemu-system-x86_64:/var/log/lxd/<VMNAME>/qemu.conf:27: There is no option group 'spice'

I have tried qemu from the cli to start a VM with a spice console and it works fine so I know the spice libs are compiled in. I have tried with both the qemu and qemu-headless variants of qemu.

Any ideas?

Thanks in advance!

Thanks! I had seen that but I was just not quite sure if it definitely applied in this case. Unfortunately that has been open for a month now and it is not even assigned to someone to get it fixed. Hopefully it gets prioritized soon.

Yeah, if you have any control on your distro packaging, building qemu with --disable-modules will sort it out, that’s effectively how qemu was always built in the snap package and why we didn’t get affected when moving to 5.2.

I reverted the installed version of qemu back to 5.1.0 and it is working now. Thanks again!