Lxd launch from remote server: Access violation

Hi, I have setup my LXD repository

lxc config set core.https_address :8443
lxc config set core.trust_password hunter2

added on my client host:
lxc remote add foo https.........
accepted fingerprint and password.
But when I try to launch image, it fails with error
lxc launch foo:mytemplate myname

Error: Failed container creation:
 - https://192.168.x.x:8443: Get https://192.168.x.x:8443/1.0: Access violation
 - https://:8443: Get https://:8443/1.0: Access violation

curl -k https://192.168.x.x:8443 works and returns JSON reply

If it helps, on remote LXD, mytemplate container image is set to Public:NO, changed it to Public: true, did not help.

does it work when trying the launch directly on the remote ?
what are the configuration (os and lxd versions) of the 2 computers ?

Yes, it works when I run on remote.
remote: debian 9.9, lxc 3.13

client: debian 9.6, lxc 3.7

Just FYI, on client I am able to launch containers from public repositories.

Problem was that lxc client was configured to use proxy. removed proxy, solved problem.

lxc config show
lxc config unset core.proxy_http
lxc config unset core.proxy_https