Manual lxd.migrate ? deb version not installed anymore

I have upgraded to Ubuntu server 20.04 Focal from 16.04 Xenial and removed the LXD and LXC packages already before.
Now with the LXD snap installed lxd.migrate gives me:

=> Connecting to source server
error: Unable to connect to the source LXD: Get "http://unix.socket/1.0": dial unix /var/lib/lxd/unix.socket: connect: connection refused

Trying to install the apt version of lxd leads to the same result.

How can I migrate my containers manually?

Reply to self:

I have added bionic and bionic-updates to /etc/apt/sources.list

Then ran

apt install lxd=3.0.3-0ubuntu1~18.04.1 lxd-client=3.0.3-0ubuntu1~18.04.1

And that worked flawlessly :slight_smile:

Excellent, that’s definitely a better approach than doing it fully by hand as it’s easy to overlook something lxd.migrate does (like mangling zfs mounts, …) and end up in a bit of a confused state.

Im having a similar issue except i can’t get apt lxd to run. I have installed it but the command to start the service hangs and never completes.

Look in /var/log/lxd.log and journalctl -u lxd for an indication of what may be wrong.