Migrating image server to a new host

I have been using my own image server successfully for some time.

However, now I had to migrate it to a new one (I run out of space in the old one, cannot expand it).

I have created the new one exactly like in the documentation, just with:

lxc config set core.https_address "[::]:8443"

and opening the port in the firewall (AFAIK these are the actions I did the last time).
Then I re-uploaded all the images and made sure they are all public.
The url is the same (I changed the IP/DNS entry).
I have confirmed that I can access the image server from the nodes.

However, the images in the existing nodes don’t autorefresh anymore.

I have removed the remote and added it again with:

lxc remote remove image-repo
lxc remote add image-repo imagerepohost --public --accept-certificate

I get no errors here.

I have also tried without --accept-certificate and I get this:

Certificate fingerprint: acff0e221053ca88f93c92c84de424a4ffda99e8864f3a9923bf345b0b166c0e
ok (y/n)? y

So I assume it is working fine and can be accessed.

However, if I try to refresh an image manually, I get this error:

~# lxc image refresh image-repo:image-name
Error: The remote isn't a private LXD server

What am I missing?

Any help would be very appreciated, thank you!

OK, I found out that if I do:

lxc image copy image-repo:image1 local: --alias image1

then it works, it brings the images correctly from the new server.

I wonder now if this workflow is conceptually incorrect, and I shouldn’t bring the images locally?

Will the new ones auto update?
Thanks, best