Permission denied when trying to ssh into lxc container?


#1

Figured it out. I was using the wrong IP to connect. I needed to do lxc-ls -f to find the correct IP.

I am trying to ssh connect locally.

I want ssh because lsyncd needs it for sharing.

gives permission denied. That is the ip that shows on my host for the container when I did ifconfig.

I already added PermitRootLogin to Yes in /etc/ssh/sshd_config and it made no difference.

What can be causing this permission denied? I turned off firewall in the server and no change.


(Brian Mullan) #2

10.0.3.1 is probably the IP of the LXCBR0 bridge that connects your host and any LXC containers.

$ ifconfig

Should show that