Removal of the default fake qemu gpu

I am trying to add a gpu via passthrough to a vm, such that its output is rendered to a different monitor. However, the default qemu GPU is chosen as primary, and therefore does not output anything to the monitor.

If I comment out the qemu_gpu device in the qemu.conf file, and force it to load this config, everything works.

Are there any way to disable the default qemuGPU device/option?
This is the point I’m talking about in the code:

Thanks! LXD is awesome!

Hmm, no, we always keep that GPU because that’s what lxc console --type vga connects to and SPICE wouldn’t setup properly if there wasn’t a virtual GPU.

If at all an option, it’d likely be much better to have the guest OS turn off the primary GPU or re-order the displays to have it be treated as a secondary GPU.