Reuse existing pool for new instalation

I had a clustered LXD installation before and I had been using a btrfs pool for it on every node. I accidentally reinstalled the LXD and all my LXD configs are gone, but the storage pool is there and I can see the files there by mounting the pool.

I tried to make it back by following, but no luck:

$ lxd init
Would you like to use LXD clustering? (yes/no) [default=no]: yes
What name should be used to identify this node in the cluster? [default=floss-1]: 
What IP address or DNS name should be used to reach this node? [default=]: 
Are you joining an existing cluster? (yes/no) [default=no]: 
Setup password authentication on the cluster? (yes/no) [default=yes]: 
Trust password for new clients: 
Do you want to configure a new local storage pool? (yes/no) [default=yes]: 
Name of the storage backend to use (btrfs, dir, lvm, zfs) [default=zfs]: btrfs
Create a new BTRFS pool? (yes/no) [default=yes]: no
Name of the existing BTRFS pool or dataset: /dev/mapper/datavg-datalv
Do you want to configure a new remote storage pool? (yes/no) [default=no]: 
Would you like to connect to a MAAS server? (yes/no) [default=no]: 
Would you like to configure LXD to use an existing bridge or host interface? (yes/no) [default=no]: 
Would you like to create a new Fan overlay network? (yes/no) [default=yes]: 
What subnet should be used as the Fan underlay? [default=auto]:
Would you like stale cached images to be updated automatically? (yes/no) [default=yes] 
Would you like a YAML "lxd init" preseed to be printed? (yes/no) [default=no]: yes
  core.trust_password: "***"
- config:
    bridge.mode: fan
  description: ""
  managed: false
  name: lxdfan0
  type: ""
- config:
    source: /dev/mapper/datavg-datalv
  description: ""
  name: local
  driver: btrfs
- config: {}
  description: ""
      name: eth0
      nictype: bridged
      parent: lxdfan0
      type: nic
      path: /
      pool: local
      type: disk
  name: default
  server_name: floss-1
  enabled: true
  member_config: []
  cluster_address: ""
  cluster_certificate: ""
  server_address: ""
  cluster_password: ""

Error: Failed to create storage pool 'local': Failed to create the BTRFS pool: /dev/mapper/datavg-datalv appears to contain an existing filesystem (btrfs).
ERROR: use the -f option to force overwrite of /dev/mapper/datavg-datalv
btrfs-progs v4.15.1
See for more information.

How can I use the same storage without reformatting it?

You can’t have LXD re-import things that way.
You need to follow the disaster recovery part of our backups documentation.

Oh. I tried to recover them and I got this:

$ sudo lxd import searx
Error: Create container: Unknown configuration key: volatile.idmap.current
$ sudo lxd import microblog
Error: Create container: Unknown configuration key: volatile.idmap.current

Sounds like you’re trying to perform the lxd import on a version of LXD older than the one the containers were last run on.