Slow I/O on default.img file when using duplicity

  • Distribution: Ubuntu
  • Distribution version: 18.04
  • Storage pool : zfs
  • lxd version: 3.0.3

Issue description

I am using duplicity to backup my hosts and the lxd containers on my hosts which are using a zfpool disk (default.img) for storage. On one of these hosts i am running gitlab in an lxd container and exactly on this host duplicity is very slow on I run pv -d "$(pgrep -u $USER duplicity)" I am getting an I/O speed of max 400KiB/s for the file default.img[0] while on the other hosts the I/O speed for this file is about 40 MiB/s[1]. I tested the I/O performance on the host, it’s actually very good and seems to be same speed as on the other hosts. I done a test on a separate Host so i ran duplicity before installing gitlab in an lxd container and a test after installing gitlab and I had the same issue on this host. I don’t really know how to debug this problem. Any help?

note: actually the installation process of gitlab inside lxd container using curl | sudo bash takes unusual long time about 20 min.