Storage volumes cannot be specified as absolute paths

lxc profile list

+---------+---------------------+---------+
|  NAME   |     DESCRIPTION     | USED BY |
+---------+---------------------+---------+
| default | Default LXD profile | 0       |
+---------+---------------------+---------+

lxc profile show default

config: {}
description: Default LXD profile
devices:
  eth0:
    name: eth0
    network: lxdbr0
    type: nic
name: default
used_by: []

lxc storage list

+---------+--------+---------------+-------------+---------+---------+
|  NAME   | DRIVER |    SOURCE     | DESCRIPTION | USED BY |  STATE  |
+---------+--------+---------------+-------------+---------+---------+
| default | dir    | /home/storage |             | 0       | CREATED |
+---------+--------+---------------+-------------+---------+---------+

lxc profile device add default root disk source=/home/storage pool=default

Error: Device validation failed for “root”: Storage volumes cannot be specified as absolute paths

When using “pool” setting you have to provide a pool name in “source” setting.

1 Like

Not sure I understand

like this?

lxc profile device add default root disk source=default pool=default

I’m trying to join my default storage pool to my default profile

lxc profile device add default root disk source=default pool=default

worked great!