Unable to start a container after restore from snapshot

I can’t start a container after a restore. I got the following error:

lxc start owncloud
Error: Failed preparing container for start: Failed to handle idmapped storage: Failed to change ownership of: /var/snap/lxd/common/lxd/storage-pools/thin_vg/containers/owncloud/rootfs/cloud/data/valgonzalez/files/Backups.Digicel/Digicel2017/Data_Ontap/ONTAPdeploy2.2.2.ova
Try lxc info --show-log owncloud for more info

lxc info --show-log owncloud
Name: owncloud
Location: none
Remote: unix://
Architecture: armv7l
Created: 2020/09/17 22:47 EST
Status: Stopped
Type: container
Profiles: owncloud
owncloud-24Dic2021 (taken at 2021/12/24 12:33 EST) (stateless)
owncloud-25Dic2021 (taken at 2021/12/25 16:45 EST) (stateless)


I tried to copy the container to a new one, but I got this error:
lxc copy owncloud/owncloud-25Dic2021 newcloud
Error: Create instance from copy: Failed to run: resize2fs /dev/thin_vg/containers_newcloud 9765625K: resize2fs 1.45.5 (07-Jan-2020)
resize2fs: New size smaller than minimum (108166189)

Im using lvm backend. I tried to mount the container logical volume, but I can activate it.
– Logical volume —
LV Path /dev/thin_vg/containers_owncloud
LV Name containers_owncloud
VG Name thin_vg
LV UUID TgX7ah-Ibt2-q0Bh-6fV5-2czk-NXXP-Be0jPQ
LV Write Access read/write
LV Creation host, time cloud309, 2021-12-25 19:42:19 -0500
LV Pool name LXDThinPool
LV Thin origin name containers_owncloud-owncloud–25Dic2021
LV Status NOT available
LV Size 610.00 GiB
Current LE 156160
Segments 1
Allocation inherit
Read ahead sectors auto

I read some of your post, but I can resolve this issue. Can anyone help?

Hi @valgonzalez,
I’m not sure whether working or not but could you try like that.
lxc publish owncloud/owncloud-25Dic2021 --alias=newcloud
lxc launch local:newcloud newestcloud

Hi @cemzafer,

I got this error running the command you aks.

ubuntu@cloud309:~$ lxc publish owncloud/owncloud-25Dic2021 --alias=newcloud
Error: signal: broken pipe

Any other advice?

Post the output please lxc publish owncloud/owncloud-25Dic2021 --alias=newcloud --debug


I thing the problem is the FS space. I thought the command would use LVM to run the plubish image. It using root FS. I don’t have enough space to store this container. There is around 500GB of data.

Is there a way to send the publish output directly to LVM volume group?


I have a remote nfs FS with enough space to store the entire container. I’m trying to do an lxc export, but the process still using the root FS.

Any advise about this?

Hi @valgonzalez,
If taking backup of snapshot is not the case why dont you export related container to your nfs path.
lxc export --instance-only --compression=lzma owncloud <nfs_path/name_of_the_backup>

Hi @cemzafer.

The export process is running. I think for tomorrow will be ready.