Update: More info, Fan bridge breaks when I stop container and do an Export

I ran a backup script below last night and I am experiencing a very weird problem now. I have run this script for many months without a problem, but somehow something in LXd 4.0 seems to have trigger the following problem.

MIGHT BE , that Server ran out of space in primary hard drive, even though it had plenty of space because export does not release space after using it for backup. Is there anyway to move backup temp files to zpool. Or perhaps remove them after export before the next one happens.

When I stop container, do the export and then restart the container. Everything seems fine. Container comes up, and script goes to the next. Unfortunately, the website no longer functions because the IP routing is somehow damage. I have tried to start/stop/reboot container etc… not avail. What works to fix it is to copy container to a new container within same server wstrong texthich makes it get a new ip. Which I then have to change in nginx proxy at server level. Then it works fine.

After my backup script ran about a fourth down my containers, I spent all night and probably all morning fixing every container manually. I am also worried that since I copying every container twice I might run out of fresh IPs and possibly space. Anyway to see where the disk space went ?

Trying to see what could be cause and long term effect of this problem. Could it be causing some corruption in Database or somewhere else?


See script below, it is pretty harmless and simple.

echo ‘-----------------------------------------------------------’
echo ‘Backing up’ $1
lxc stop $1
echo ‘Container stopped, starting backup’ $1
now=$(date +"%Y_%m_%d")
time lxc export $1 /media/BACKUP/QBACKUP/$1-$now.tar.gz -v
echo ‘Backup complete’
lxc start $1
echo 'Starting up ’ $1