Failing to connect to container using x2go

Well sorry their “free” community support didn’t work for you…


many of the x2go developers have been working on a new project called Arctica
Arctica Project

I did a little looking at the project. Seems to be interesting but except for some fixes a few days ago the bulk of the project seems quite stalled - - - there doesn’t seem to be any activity in about a year.

Do you have any information that is more direct about what is being worked on?

Hadn’t tried it yet - - - just have been subscribed for quite some time (IIRC about 9 months) and only recently have a few questions come through. To me that suggests a very seldom used support system.

@simos and @stgraber (The later part of the message is part networking and part lxd behind-the-scenes so I added you to this connection.) (If this is not the way to do this please advise!)

Doing some more digging!
I was comparing 2 containers - - -1 where I CAN use x2go and one of the debian-sid versions where I CAN’T use x2go.

The container where I can use x2go:
root has no Xauthority file - - - yet user does
so the command $ xauth list $DISPLAY
gives a total of 8 (!) ‘MIT-MAGIC-COOKIE-1’

where I cannot use x2go:
root has no Xauthority file and
$ xauth list $DISPLAY
xauth: timeout in locking authority file /home/memyself/.Xauthority

Another interesting point is that these containers where I do have x2go working were all set up using lxd 2.xx and I am now working on lxd 3.00 (IIRC).

On the older containers when I log into userID (using $ su userID) the command line reads:
userID@containername:/root$ (The folder name after the/ is unimportant I believe)

yet on the newer containers when I log into the userID (again using $ su userID) the command line now reads just $ (with nothing after the symbol at all).

Are there some changes in the background between lxd2 and 3 that are not helping this mission?