Incus LTS vs Stable for Ubuntu 24.04 - win 11 vm did not work with LTS but works fine with stable


I am wondering what the major differences are, at the moment, between incus 6.x LTS and 6.0 stable?

I migrated to Ubuntu 24.04 from 22.04 via fresh install and I used the main apt repo to install the LTS incus. One of my alpine containers did not want to play nice during the first few import attempts but I did finally get it going. My win11 vm however did not want to work no matter what I tried while using incus LTS. I uninstalled & purged multiple times and retried my import but it just would start. Foolishly, I did not save a copy of the initial message displayed when trying to start the vm, but I do have a copy of the text from the log:

“qemu-system-x86_64:/run/incus/win11-01/qemu.conf:247: Failed to connect to ‘var/lib/incus/virtual-machines/win11-01/tpm.vtpm/swtpm-vtpm.sock’: No such file or directory”

Finally I decided to uninstall and purge the LTS version and added the stable repo from the zabbly github page. I installed the stable version and everything worked the first time around. Something worth noting, it did take as long if not longer to import my larger container and the win11 vm. Not complaining about that though because I am just glad it worked.

Did you still the swtpm-tools package?

The Debian/Ubuntu native packages focus on containers and so a bunch of support packages for VMs must be installed by hand. It’s also possible that some of those extra packages don’t function properly which could be the issue here.

Note that you can get lts-6.0 from Zabbly too to get the same 6.0.0 version but with our “fat” packages that include everything bundled in. Incus 6.1 is about to come out to the stable repository and we don’t support downgrades, so if it’s important to you to have the LTS on your systems you should make sure to use the lts-6.0 repository.

Hi @stgraber!

No, I did not install the swtpm-tools package. I did quite a bit of online searching and did not even see that come up anywhere. Thanks a lot for that tidbit. It’s not super important to me to use the LTS release, but now I want to test it out with the swtpm-tools package. I will report back and let you know of the outcome.