LXD on Windows 10 WSL?


#21

Maybe I am confusing you. I am only interested in running Multipass and not LXD.
I run multipath launch. The insances are created, but they will not start.

Ray


#22

But you wouldn’t mind running LXD under multipass on Windows for a mere test so that this thread is relevant to the forum, right?

There are three specific requirements mentioned earlier, and I need from you to positively state that you have checked them, so that we know that multipass should work. Can you do that?

  1. Only Windows 10 Pro or Enterprise , build 1803 or later is currently supported.
  2. Make sure the network you’re connected to is marked Private (which really means Trusted ), otherwise Windows will prevent Multipass from starting. We’re working on resolving that issue.
  3. You will need to allow the installer to gain Administrator privileges.

Apart from that, there is support for multipass on the Ubuntu discourse website. Here is a list of tagged posts for multipass. You would post there a support question for multipass and tag it with the multipass tag to get the attention of the multipass developers.


#23

So…I am running Windows 10 Pro over WiFi which is marked Private.
For installer, you mean the Multipass installation on Windows 10?

Thanks,

Ray


#24

The requirements I wrote above in italics are copied from the multipass page. I used italics to denote that this is copied text.

The installation instructions that I gave earlier, refer to a GitHub download page that has an installer named multipass-0.6.0+win-win64.exe
This is the installer.

If you completed the installation without an error, then you can launch a VM with multipass.


#25

So that’s my problem.

I uninstalled multipass and re-installed as administrator. That worked fine.
Then I did a multipass launch -n rayj
It took awhile…about 5 mins. I thought this was going to work.
But then is stopped with “launch failed: time out waiting for instance response.”

“multipass list” shows rayj STOPPED release Ubuntu 18.04 LTS

Ideas?

Ray


#26

So I did a few things:
Uninstalled Multipass and reinstalled. No help.
Turned on Virtualization in BIOS. No help.
Joined the HyperV Administrator group. Helped somewhat.

I now have 2 instances marked as RUNNING. However the IPv4 addresses are marked UNKNOWN?

Any ideas?

Ray