Old containers can reach internet after ubuntu 22.04 upgrade

As the title says my containers cant reach the internet anymore. LAN is fine and if i launch a new containers with the same profile it works perfect. So what happened? ufw is disabled. portforwarding is on and as i said new containers work fine. Tried both default profile and my default macvlan.

Update: looks like its my vpn cli app that cant handle the upgrade. Worked fine in a ubuntu 20/22.04 lxc but after the upgrade it broke. Native wg works after reinstall.

1 Like

Try this:

1 Like


Someone named Stefan Fleischmann (sfleischmann) has uncovered a possible cause for this cgroup2 problem.

Read the last couple comments in the Launchpad Bug.
Bug #1971571 “ubuntu 22.04 cgroup2 works for clean install but u...” : Bugs : lxd package : Ubuntu

Doing what’s described above, I do not have to edit the /etc/default/grub
I would think that this also has the benefit of enabling use of cgroup2 instead of disabling it in /etc/default/grub.

1 Like