What qemu-setting does migration.stateful set?

Neither current OPNsense or 2.7.0 development branch of pfSense agree to run in an LXD VM without enabling migration.stateful in the VM configuration, but enabling that prevents me from passing through physical NICs, just resulting in an error-message as follows:

Error: Failed to start device "eth1": Network physical devices cannot be used when migration.stateful is enabled
Try `lxc info --show-log pfsense` for more info

I would very much prefer there being a proper fix for this in LXD, but in the meantime, how would I get the same result with e.g. raw.qemu, thereby letting me bypass that error-message and still getting a working VM?

I actually figured it out. Instead of migration.stateful, you can use raw.qemu: -cpu host in the virtual-machine’s configuration and be able to run more modern BSD-kernels while also letting you passthrough physical devices.

1 Like