Accessing LXD UI shows JSON response

Why do I get this JSON response when trying to access the LXD UI:

Screenshot from 2023-06-30 12-04-54

The LXD UI is still considered an experimental feature, you need to specifically enable it in order to get access:

snap set lxd ui.enable=true
snap restart --reload lxd

Then you should see the onboarding in the browser, which explains the setup of client certificates. You can find a more detailed guide in the docs.

1 Like

I have already tried that multiple times.

It worked for a day with the initial install from edge channel. Reinstalling also allowed me to setup client certificates again and use the UI.

Also that no longer works.

The same on my side. It does not seem that a process is running for the UI

There is no process for the UI, its a web app that is downloaded to your browser that then interacts with the LXD daemon over its REST API.

You can use the latest/stable channel and then do snap set lxd ui.enable=true and snap restart --reload lxd rather than using latest/edge.

I have tried that, it does not work.

For me only the first version from the edge channel worked until I received a newer version. From that moment I only get the JSON returned. Also when I apply the ui.enabled=true setting.

Please note that it’s ui.enable not ui.enabled, just in case the issue is a typo based on what you said in your latest comment.

1 Like

Thanks. This works.

1 Like