Adb devices shows no devices attached

Hey guys
i have setup an alpine container and added with the following command

lxc config device add <container_name> <device_name> usb vendorid=04e8 productid=6860 mode=0666

then i installed android-tools and usbutils using the following commands in the container

apk update
apk add usbutils
apk --update-cache --repository Index of /alpine/edge/testing/ add android-tools

the adb and lsusb command work in the terminal
lsusb shows the android device is connected

but adb device does not show any devices is connected

what is tge step i missed??

Hmm, I believe those steps worked for me last time I played with that.
Maybe worth checking that the device is indeed visible in /dev/bus/usb in the container and that the permissions and ownership looks correct.

thanks kinda worked after rebooting the machine

yeah funny enough i did check if the device is in that path in the container and it was there

Hey @stgraber @tomp i did a fresh debian installation and installed lxc/lxd from source and tried to add a device as described above even after restarting and rebooting the machine i could not get the usb device appear in the container

root@devout:~# adb devices
List of devices attached

root@devout:~# lsusb
Bus 002 Device 003: ID 0483:374b STMicroelectronics ST-LINK/V2.1
root@devout:~# ls /dev/bus/usb/002/003
root@devout:~# adb devices
List of devices attached

root@devout:~# exit

on the host i did add the device and the appear

aok@debian:~$ lxc config show devout
    mode: "0666"
    productid: 374b
    type: usb
    vendorid: "0483"
    mode: "0666"
    productid: "6860"
    type: usb
    vendorid: "04e8"

what might be the issue here kindly?