After installing docker lxd containers no longer getting IP over bridge

Hello,

As wrote in title…Fresh installation, installed lxd via snap on Ubuntu 18.04.02, during lxd init “wizard” assigned pre-created br0 as default network, launched first container and got IP from LAN DHCP server succesfully.
After that installed docker, no longer getting IP on lxd container, after docker removal IP assigment from LAN DHCP is working as intended…
Is it not supported to have docker and lxd at the same time and have working scenarion I described, is there any workaround? Thanks a lot in advance!

For the LXD container you are running Docker in di you set that LXD container to support"nested" containers ?

See the section labeled “How to run Docker inside LXD”

https://lxd.readthedocs.io/en/stable-3.0/

LXD and Docker run side-by-side. I did not installed Docker inside LXD…

Check iptables -L -n -v for any rule from Docker that would affect LXD networking.
We’ve seen cases where Docker somehow changes the policy from ACCEPT to DROP or REJECT, effectively causing all non-Docker traffic to be dropped…

1 Like

That was it! Flushed iptables, created bridged profile and assigned it to container which in turn got ip from LAN DHCP. Now I have to figure out how to disable offending Docker DROP rule…Many, many thanks for helping me out on this one <3