All instances disappeared after formating hard drive

There are two hard drive in my server. In despite of their existence, Ubuntu doesn’t mount them because of file format issue. So I formatted them to ext4. However, after then, lxc and lxd have both broken. I logged in LXD-UI to check previous instances but all of them have disappeared.

I tried some commands but many of them gave the same error:

lxc start --all
Error: Get “http://unix.socket/1.0”: dial unix /var/snap/lxd/common/lxd/unix.socket: connect: no such file or directory

Then I run debug command:

lxd --debug --group lxd

which outputted an error:

EROR[10-01|14:16:25] Failed to start the daemon err=“Failed initializing storage pool “default”: Failed to run: zpool import -f -d /var/snap/lxd/common/lxd/disks default: cannot import ‘default’: no such pool or dataset”

Afterward, I run

systemctl start snap.lxd.daemon.unix.socket

but it doesn’t work. The issues still exist. Those instance image were stored in a ssd not those two formatted hard drive, so I guess those instances are still there.
Does anyone have idea about how to fix this? Any help would be appreciated! Thanks in advance.

Hi, @Virux, you may recover with lxd recover tool, I suppose. Look at that link.
https://discuss.linuxcontainers.org/t/lxd-new-disaster-recovery-tool/11296
By the way, the error mentioned about zfs but in your post you have mentioned ext4.
Please post those commands output.
zfs list and if applicable lxc storage ls

Regards.