Cannot access container on new managed bridge network - which host interface is it using?

Hi, I have initially configured bridge br0 manually and use unmanaged network for LXD containers. Now I want to add additional network with DHCP and DNS on the same IP space so that I could create containers and IP addresses assigned by LXD.

Short info. Network 192.168.1.0/24, host is 192.168.1.200/24 on br0, it uses host interface eno1. Network for host and containers works fine.

New managed network 192.168.1.201/24 (192.168.1.201 is lxdbr1 interface on the host).

lxc network create lxdbr1
lxc network list
lxc network set lxdbr1 ipv4.address 192.168.1.201/24
lxc network set lxdbr1 ipv4.dhcp.ranges 192.168.1.101-192.168.1.199
lxc network set lxdbr1 dns.domain sitex.example.com
lxc network set lxdbr1 ipv4.dhcp.gateway 192.168.1.1 # another server on the network
lxc network set lxdbr1 ipv6.address none

My new profile config, I tried both but no luck:

config: {}
description: ""
devices:
  eth0:
    name: eth0
    nictype: bridged
    parent: lxdbr1
    type: nic
  root:
    path: /
    pool: local
    type: disk

And with the recommendation from here About networking - LXD documentation :

config: {}
description: ""
devices:
  eth0:
    name: eth0
    network: lxdbr1
    type: nic
  root:
    path: /
    pool: local
    type: disk

Container is created and IP gets assigned from DHCP pool range
mycont4 | RUNNING | 192.168.1.125 (eth0)

I cannot ping or access it from host, I can lxc exec into container but cannot access or ping anything.
I tried setting ipv4.nat from true to false, restarted container but no luck.

no firewall rules configured.

Update:
When I setup br0 I configured it to use eno1 as parent. How lxdbr1 works, which host interface it is using?

The problem is that 192.168.1.201/24 is in the same subnet as 192.168.1.0/24.
This is going to result in both your br0 and lxdbr1 interfaces creating duplicate routes to 192.168.1.0/24 on your system, which will wreak havoc with IP communication on those networks.

You will need to use a different subnet for lxdbr.