❯ incus admin os system storage import-storage-pool bar: -d '{"name":"foo","type":"zfs","encryption_key":"REDACTED"}'
WARNING: The IncusOS API and configuration is subject to change
Error: Failed to run: zpool import foo: exit status 1 (cannot import 'foo': pool was previously in use from another system.
Last accessed by bar (hostid=blah) at Sun Aug 9 07:24:01 2026
The pool can be imported, use 'zpool import -f' to import the pool.)
I think the question is, how do you get incus admin os system storage import-storage-pool to pass the -f flag to zpool import?
% incus admin os system storage import-storage-pool --help
Description
Import an existing encrypted storage pool
Usage:
incus admin os system storage import-storage-pool [<remote>:] [flags]
Flags:
-d, --data Command data
--target Cluster member name
Global Flags:
--debug Show all debug messages
--explain If the command is valid, explain its parsed arguments instead of running it
--force-local Force using the local unix socket
-h, --help Print help
--project Override the source project
-q, --quiet Don't show progress information
--sub-commands Use with help or --help to view sub-commands
-v, --verbose Show all information messages
--version Print version number