Can't create VMs error: no such partition error

I’m unable to create VMs on my LXD server, and I’m not sure the reason. Every time I try to console into a VM I create I get the following GRUB error:

BdsDxe: loading Boot0002 "UEFI QEMU QEMU HARDDISK " from PciRoot(0x0)/Pci(0x1,0x1)/Pci(0x0,0x0)/Scsi(0x0,0x1)
BdsDxe: starting Boot0002 "UEFI QEMU QEMU HARDDISK " from PciRoot(0x0)/Pci(0x1,0x1)/Pci(0x0,0x0)/Scsi(0x0,0x1)
error: no such partition.
Entering rescue mode...
grub rescue>

I’m running LXD version 5.2 on Arch Linux host with kernel 5.17.9-arch1-1

I’m using the following command to make the VMs:
lxc launch images:archlinux/cloud --vm --profile vm-arch --console

I’ve also tried the ubuntu:22.04 image and get the same error.

The vm-arch profile looks like:

config:
  boot.autostart: "false"
  boot.autostart.priority: "98"
  security.secureboot: "false"
  user.vendor-data: |
    # cloud-config stuff here ...
description: Arch LXD profile for virtual machines
devices:
  config:
    source: cloud-init:config
    type: disk
  eth0:
    name: eth0
    nictype: bridged
    parent: br0
    type: nic
  root:
    path: /
    pool: default
    size: 20GiB
    type: disk
name: vm-arch

The default storage is a ZFS pool:

❯ lxc storage ls
+---------+--------+--------------+-------------+---------+---------+
|  NAME   | DRIVER |    SOURCE    | DESCRIPTION | USED BY |  STATE  |
+---------+--------+--------------+-------------+---------+---------+
| default | zfs    | smoltank/lxd |             | 28      | CREATED |
+---------+--------+--------------+-------------+---------+---------+
| tank    | zfs    | tank/lxd     |             | 2       | CREATED |
+---------+--------+--------------+-------------+---------+---------+

There are no logs in lxc info --show-log CONTAINER

If anyone has any idea what I’m doing wrong I’d greatly appreciate it. I was able to create one working VM using a qcow2 image, but it seems like nothing I pull down from the web works.

Sorry to bump this, but I’m completely clueless on where to even start looking for the cause of the error. If anyone has any advice on logs/etc I could look at I would appreciate it.

Sounds like VMs on ZFS pools unbootable on hosts running kernel >=5.17. · Issue #10464 · lxc/lxd · GitHub

Thanks for the heads up. I was so confused because I knew I had had it working before.