Can't Migrate LXD to new Computer

I’m back and seemingly running into the same problems. Previously I had migrated LXD to a new SSD with great heartache (My story) but despite my travails, I got it to work.

However, today I finished my first computer build and was all ready to get LXD up and running via the Full back up method and all I get are:

a) if I copy the full /var/snap/lxd/ directory and then install LXD via snap, when I attempt to do anything LXC command, I get

`Error: Get "http://unix.socket/1.0": EOF`


b) If I install LXD via snap first, stop LXD, delete /var/snap/lxd/common and then copy the same back into the directory and try a LXC command, I still get:

`Error: Get "http://unix.socket/1.0": EOF`

I need help

journalctl -u snap.lxd.daemon -n 300 so we may get a more useful startup error.

1 Like

Thank you Stephane. As it turns out, merely suggesting the journalctl command solved my problem. As I was reading through it I saw that LXD was unable to import one of my existing ZFS pools because it was still tagged to my old server. zpool import -f <pool> solved my problem.

Thank you!