Can't see rootfs

i can’t see rootfs under my container_name from lxd master host.
i running ubuntu 20.04 LTS and
dppkg -l | egrep -e lxd -e lxc return
lxd-agent-loader 0.4 all LXD - VM agent loader

I’m not sure what you are trying to do, please can you explain further.

should be a rootfs or what?

Users aren’t supposed to directly access those paths, there’s no guarantee that they’ll be mounted/available at any given time nor that the permissions/ownership won’t be shifted, making direct modifications potentially disastrous from a security point of view.

That being said, you can peak at what’s currently used through /var/snap/lxd/common/mntns/var/snap/lxd/common/lxd/storage-pools/

Thank you. it fine.
resean i want to see was. i cant mount a storage to lxd. i used documentat

but when i start lxd i don’t have write permission. I add 777 before add and now i have permission. But it don’t like it because i open for all.

If on Ubuntu, shiftfs can fix such issues:

  • sudo snap set lxd shiftfs.enable=true
  • sudo systemctl reload snap.lxd.daemon
  • lxc restart CONTAINER-NAME
  • lxc config device add CONTAINER-NAME MY-DISK disk source=/path/on/host/ path=/path/in/container/ shift=true

Thnaks it’s working.