My cephadm cluster has been yelling at me to replace the aes keys in it’s health checks, so I went about doing that, however it seems that ceph/the kernel/something isn’t new enough for the aes256k keys? My cephfs storage pool is printing the following in the event log:
context-err="Couldn't get fsid for \"camnet\": Failed to run: ceph --format json --cluster camnet --name client.incus fsid: exit status 1 (2026-10-01T19:02:38.376-0400 7f40c31e96c0 -1 auth: error parsing file /etc/ceph/camnet.client.incus.keyring: error setting modifier for [client.incus] type=key val=AgC1eb5qroCNEyAA0oPwCweJsVHfy81q3hdOlCLDhwa+xZvl9O+VUwc6FjQ=: Malformed input [buffer:3]\n2026-10-01T19:02:38.376-0400 7f40c31e96c0 -1 auth: failed to load /etc/ceph/camnet.client.incus.keyring: (5) Input/output error\n2026-10-01T19:02:38.377-0400 7f40c31e96c0 -1 auth: error parsing file /etc/ceph/camnet.client.incus.keyring: error setting modifier for [client.incus] type=key val=AgC1eb5qroCNEyAA0oPwCweJsVHfy81q3hdOlCLDhwa+xZvl9O+VUwc6FjQ=: Malformed input [buffer:3]\n2026-10-01T19:02:38.377-0400 7f40c31e96c0 -1 auth: failed to load /etc/ceph/camnet.client.incus.keyring: (5) Input/output error\n2026-10-01T19:02:38.377-0400 7f40c31e96c0 -1 auth: error parsing file /etc/ceph/camnet.client.incus.keyring: error setting modifier for [client.incus] type=key val=AgC1eb5qroCNEyAA0oPwCweJsVHfy81q3hdOlCLDhwa+xZvl9O+VUwc6FjQ=: Malformed input [buffer:3]\n2026-10-01T19:02:38.377-0400 7f40c31e96c0 -1 auth: failed to load /etc/ceph/camnet.client.incus.keyring: (5) Input/output error\n2026-10-01T19:02:38.377-0400 7f40c31e96c0 -1 monclient: keyring not found\n[errno 5] RADOS I/O error (error connecting to the cluster))" context-pool="cephfs" level="error" Failed mounting storage pool