Ceph storage - incus can't see a block volume

I have an external Ceph cluster (. Server has a defined storage of type ceph (so RBD). I’ve created a custom volume on ceph storage with

incus storage volume create ceph disk --type=block size=50TiB

This disk was attached to a VM. Everything worked, but now I rebooted a host and incus can’t see this particular volume anymore. Ceph storage is fine, I can create other volumes on it. If I look directly on the ceph pool, the volume is still there and looks ok:

$ sudo rbd --name client.incus --cluster ceph  --pool rbd.incus list

How can I import this volume back into incus? I don’t want to loose data stored in it, so I haven’t tried to just create the same volume again. Host is Ubuntu 22.04, Incus 0.6 from zabbly packages, Ceph 18.2.0.

Can you show incus project list?

The name above suggests that the disk block volume is inside of a project named project.
Which would then make it visible only in incus storage volume list ceph --project project

yes, its in a nondefault project, but I’ve switched to it (and doublechecked by using --project parameter). Incus can’t see this volume, but sees (lists) other volumes I’ve created now.

Okay, that’s odd. Can you show incus admin sql global "SELECT * FROM storage_volumes" to see if there’s any sign of it left in the database?

If not, then incus admin recover should be able to get it back in there.

incus admin recover was the solution for this. Thanks!