Change log level

Hey there,
I’ve noticed that after upgrading from LXD version v4.0.9 to v5.0.0 the log level in /var/snap/lxd/common/lxd/logs/lxd.log now is changed and I no longer see info messages by default. How do I change this back to log the info messages? Thanks.

Ah, that must have been a bug. The expectation has always been that verbose would give you info and debug would give you, well, debug. So the default would be warning and higher.

LXD 5.3 will have a new daemon.verbose config option which I’ve just added now so you can turn it on with snap set lxd daemon.verbose=true. In the mean time, you can either turn on full debug with snap set lxd daemon.debug=true or you can watch the verbose log through lxc monitor --pretty --type=logging --loglevel=info


Also just noticed this:

1 Like