Container config recreates volatile properties?


#1

I’m trying to remove:

volatile.lxdbr0.hwaddr: 00:16:3e:61:9e:6f
volatile.lxdbr0.name: eth1

From an Alpine container, as this creates a duplicate interface I don’t want/need. Unfortunately, once I remove these lines from the config (via lxc config edit a1) and save the changes, LXD silently reinstates these lines. The container is not running during these steps. Any idea why this might be happening?

My LXD bridge is set up such that DHCP is disabled, if that matters.

p.s. Same with an Ubuntu container as I just confirmed, so nothing Alpine specific.


(Stéphane Graber) #2

Can you show lxc config show --expanded NAME for your container?

Most likely the issue is that you have two nic devices to it through profiles which is causing the issue. The volatile keys are just normal part of dealing with existing devices, they don’t by themselves cause devices to appear.


#3

You’re correct Stéphane, --expanded listed another nic device I wasn’t aware of. I detached the bridge from the profile used by the containers and now the phantom device and persistent volatile items are gone. Thanks! :+1: