Container creation fails after switching LVM FS

lxd

#1

I'm using LXD 2.20 on debian stretch, installed using snap and a LVM storage backend for my containers.
Everything worked fine until i tried to change the lvm fs type lxc storage set lvmpool volume.block.filesystem xfs
Afterwards lxc launch images:debian/buster testcont (a new image) results in the command downloading the image but not terminating. i had to terminate pressing Ctrl-C thrice. 'lxc list' shows the container, but 'lxc start testcont' does not start the container. it also does not terminate.
Containers which were created earlier can still start.
Deleting all containers, all images and all volumes does not help.
Switching back to ext4 using lxc storage set lvmpool volume.block.filesystem ext4 does not help either.
If you need more information i would be happy to provide. Thank you for helping.


(St├ęphane Graber) #2

If you look at ps fauxww are you seeing some stuck lvcreate processes in there?

I've seen the kernel have a pretty hard time with LVM lately, leading to completely stuck (D state) lvm processes.