Containers have no network access

I was fairly new to lxd before the switch to incus. however, lxd setup seemed pretty straight forward. I followed startup guides and successfully created several containers. networking worked fine for lxd.

now I recently switched from manjaro(arch based) to mxlinux(debian 12 based) and I am attempting to re-setup incus.

following the steps outlined in the docs, I get installed and create my first container. however, the container has no ip address. and obviously no network access.

the incusbr0 bridge is created and everything looks ok but no address is provided to the container.

I have deleted everything several times and restarted, reinstalled and reconfigured everything. however still an issue.
the networking docs for incus seems way over my head. with lxd on manjaro it just worked.

I am not sure if it is a problem with incus or with mxlinux.

how to troubleshoot???


I am an idiot.
I dismissed the firewall troubleshooting because I was unaware that mxlinux was running one by default.

all good now