Cosmic containers allow Snap installs without any extra config

After some frustrating hours poking away at profiles, getting unmarshal errors, udev errors and so on, out of frustration I spun up a new container with the latest ubuntu-daily:cosmic image and default profile (just a dir-backed storage root and standard configured lxdbr0 nic). Inside the container snaps for core and LXD 3.6 are installed as part of the OS, and I’m able to (sudo) install more snaps. Squashfuse seems to not be installed inside the container.


To make things interesting, the above statement is only true in an unprivileged container! I did the above with a privileged profile setting security.privileged = true, unconfined apparmor and a couple of cgroup device allow rules, and Snap is sulking again. Installing squashfuse doesn’t fix it :frowning:

I’m now back to the point I was at with bionic containers:
ERROR run hook "install": cannot perform operation: mount --rbind /mnt /tmp/snap.rootfs_hmGjJr//mnt: Permission denied

It’s probably time to return to apt packaging for the time being. This means Cosmic is out of the picture, unless additional repos are available to Cosmic for installing LXD from apt (the Cosmic LXD package installs the Snap version).