Cri-o installation crashing Incus agent in rocky linux 9 VM

I am having fun setting up Kubernetes cluster using LXC VM’s and Rocky Linux 9.

After noticing that after setup and reboot, I cannot login to VM anymore. I figured that crio package is causing this issue.

lxc list is showing that all VM’s are running but I cannot login into shell.

All these commands are producing the same output:

lxc shell kubemaster
lxc exec kubemaster bash
lxc file edit kubemaster/etc/hosts
Error: Failed to connect to lxd-agent

After checking the VM’s boot logs. I saw that some processes are failing to start.

[FAILED] Failed to start Incus - agent.
[FAILED] Failed to start Journal Service.
[FAILED] Failed to start Load Kernel Modules.
[FAILED] Failed to start Generate n…nits from Kernel command line.
[FAILED] Failed to start Apply Kernel Variables.
[FAILED] Failed unmounting /run/incus_agent.

I tried couple of time with Rocky 8 and 9 compatible packages but it’s the same.

Any solution to this problem?

Tried in Centos9 as well, same behaviour.
I know that they are basically the same OS but I I gave it a shot anyways.
As soon as I do this and reboot, I am no longer able to login to the VM:

sudo dnf -y install cri-o cri-tools
sudo systemctl enable --now crio
sudo systemctl status crio

Works on Ubunutu 22. Strange :thinking:
If someone could check why crio installation is affecting Incus and thus disabling login to VM in RHEL derivates, that would be great :+1:

OK, I was really motivated and in a good mood so I deleted all my LXD containers and installed Incus and Rocky Linux 9 from scratch.
It’s the same!
As soon as I install crio-o, enable it and reboot, I am not able to login to VM.
Network is still working though so I might use ssh lol

Can someone also confirm this so that I dont feel like black sheep?

P.S. I cannot edit tags anymore. So this is not LXD issue only but Incus as well.