Disable PXE boot for LXD virtual machine

I’d like to boot an LXD VM off of an ISO, but I don’t want PXE to get in the way. Is there a virtual machine configuration option that I can set, which will disable PXE booting entirely?

I know about boot.priority on the disk device configuration, but I’d still prefer a mechanism to completely disable PXE.

There’s no way for LXD to control that as it’s a UEFI firmware setting.
We can influence the priority of specific devices (as you mentioned) but we don’t have control over the boot entries directly.

You can manually go and change it from the VM’s firmware menu though.

I’ve been searching and can’t figure out how to access the VM firmware menu. Any tips? Tried DEL key, F12 key, F11 key …

ESC within the first 3s of VM startup when using the LXD snap, if not using the snap, the delay depends on your distro’s EDK2 build.

lxc start NAME --console=vga is a good way to do this without missing the splash screen.

1 Like

That works, thanks