Discourse Forum Hosted in Incus

I have been trying to host a new Discourse forum in Incus without luck. I have an established Discourse forum that I had hosted in LXD three years ago and it converted to Incus and runs great in Incus. Discourse uses the docker overlay2 file system which is incompatible with zfs. So, my existing Discourse container lives in a “dir” pool and runs fine. I have tried to create new a discourse forum in Incus being sure to place it in a “dir” pool. I have security.nesting=true since the standard install of discourse uses docker. The extensive install script completes without error. At the conclusion of the install process, I get either a “this site cannot be reached” or an NginX landing page. Rarely do I get the actual Discourse setup web page. I cannot find any errors in their log file, but it seems to just not run in incus. This is baffling since I have a three year old Discourse container running in Incus that was converted from LXD and looking at the “info” I see no difference in my container.

I have even tried to create the container as “privileged” thinking it needed something from the host.

I bridge the container to my LAN and I directly expose it to my WAN address during my install tests:

incus launch images:ubuntu/22.04 Discourse --profile default --profile bridgeprofile --storage dirpool -c security.nesting=true -c security.privileged=true -c boot.autostart=true

The install is via the standard recommended Discourse script in their recommended folders:

git clone https://github.com/discourse/discourse_docker.git /var/discourse
cd /var/discourse

Like I said, this works completely without error and it just doesn’t go into the setup web page from the browser upon completion except once in every 40 installation attempts. What am I missing?