Does Incus suport creation of Windows 11 VMs ? Are the steps more or less identical to LXD & Windows 11?

I looked but didn’t see any mention of this but I am assuming the Incus can create and run a Windows 11 VM like LXD did.

If Incus does support this do I assume I follow the same Win11 VM creation steps with Incus as I used with LXD except of course substituting “Incus” for “lxc” in all the commands?


Something has changed with LXD or Qemu or the Ubuntu Kernel as recently as two weeks I had multiple LXD Windows 11 VMs running great.

Then this week, none of those same Windows 11 VMs can fully boot.

They start to boot then after ~25-30 seconds the VGA Console disappears and the LXD Windows VM goes into the STOPPED State.

Ubuntu VMs work as expected and continue to run.

I’ve tried every possible way to get any of my previously working Win11 VMs to fully boot/install.

I even freshly installed ubuntu 22.04.3 and LXD 5.19 on a separate machine.

Tried to create a new Windows 11 LXD VM using

I followed these i as I’ve done many times before.

Starting the new Win11 VM

$ lxc start win11 --console=vga

The initial Windows Install “window” pops up.

I click “Next” to continue.

A spinning ball appears on the screen.
TOP shows qemu-system using 100% cpu!
After about 25 seconds the Win11 Installation window disappears
and qemu-system is gone from the TOP display.

$ lxc ls shows the win11 VM in a STOP state no longer running.

I figured I would see if I can successfully create and run a Win11 VM using Incus.


Yeah, instructions should be basically the same, using an official Windows 11 ISO, use distrobuilder to convert it, make sure that your host machine has a CPU that’s compatible with Windows 11 and make sure to add a TPM to the VM.

I’ve got a couple of Windows 11 VMs running just fine on Incus.

Thanks Stephane. I’m hoping whatever is going on with LXD on Ubuntu 22.04.3 thats causing
Windows 11 VMs to not start is not affecting incus. I had several LXD Win 11 VMs that had been working fine for months just fail to start (lxc start cn1 --console=vga) as of 1-2 weeks ago.
The “session” dies and “lxc ls” shows the VM in a stopped state?

So I’ll install incus this weekend and see how it goes.

Okay, will be interesting to see how that goes.

I’ve never had my win11 VMs fail on LXD either prior to my switch to Incus, so I’m not sure what may have changed on their end to explain this.

Incus uses a different QEMU version than LXD these days (unless they caught up), but again, nothing that should really matter for this.

If it still fails with Incus, it’ll be interesting to try to figure out exactly why.

Funny you mentioned Qemu versions… I had been suspecting that may be a possible cause for what I’m seeing.

It did fail with Incus just like it did with LXD.

I had spent a week trying to figure out what was causing it but when win11 failed to run on Incus and LXD I finally gave and just reinstalled Ubuntu 22.04.3 and restored my /home from backup.

Now both Incus & LXD are running Windows 11 as a VM OK again.