Errors while trying to build containers

hi everyone, i am trying LXD and when i try to build the first container, i keep getting errors. no matter what i try to tinker, i keep getting the same error. here is the output of lxc info --show-log local:arch1
Name: arch1
Location: none
Remote: unix://
Architecture: x86_64
Created: 2022/05/25 16:44 WIB
Status: Stopped
Type: container
Profiles: default


lxc arch1 20220525094542.833 ERROR conf - conf.c:lxc_map_ids:3668 - newuidmap failed to write mapping “newuidmap: uid range [0-1000000000) → [1000000-1001000000) not allowed”: newuidmap 15375 0 1000000 1000000000
lxc arch1 20220525094542.833 ERROR start - start.c:lxc_spawn:1791 - Failed to set up id mapping.
lxc arch1 20220525094542.833 ERROR lxccontainer - lxccontainer.c:wait_on_daemonized_start:877 - Received container state “ABORTING” instead of “RUNNING”
lxc arch1 20220525094542.834 ERROR start - start.c:__lxc_start:2074 - Failed to spawn container “arch1”
lxc arch1 20220525094542.834 WARN start - start.c:lxc_abort:1039 - No such process - Failed to send SIGKILL via pidfd 45 for process 15375
lxc 20220525094547.878 ERROR af_unix - af_unix.c:lxc_abstract_unix_recv_fds_iov:218 - Connection reset by peer - Failed to receive response
lxc 20220525094547.878 ERROR commands - commands.c:lxc_cmd_rsp_recv_fds:127 - Failed to receive file descriptors for command “get_state”
please help me. my OS is gentoo using openrc.

What is the contents of /etc/subuid and /etc/subguid?

thank you for trying to help me, you’re right i had to change /etc/subuid and /etc/subguid, configure cgroupv1 and cgroupv2 and other configuration i forgot, the container is working now after all of that

the containers worked some time then there was a change in the configurations which is a system app that stores the changes made in config files then gives the users the options to merge the new configs or discard them so i discarded them, i don’t know why but the internet connexion of the containers has been lost and the containers no longer have ip addresses. i tried to find where the problem is and copy some configs from other machines with working containers but did not work i deleted lxc and lxd and reinstalled them but still the same the output of lxc info | grep ‘firewall:’ is
firewall: xtables