Failed to launch Windows 11 VM using incus due to an error related to block device setup

I followed the tutorial How to Install a Windows 11 VM using LXD on Ubuntu’s official website to set up a Windows 11 VM using incus. However, I encountered the following error during the VM launch:

incus start win11 --console=vga

Error: Failed setting up device via monitor: Failed adding block device for disk device "install": Failed adding block device: aio=native was specified, but it requires, which was not specified.

Steps to Reproduce:

  1. Followed the steps outlined in the tutorial to set up a Windows 11 VM using LXD.
  2. Encountered the mentioned error during the VM launch.

Expected Behavior:
The Windows 11 VM should launch successfully without encountering any errors related to block device setup.


  • Host OS: Linux Mint 21.3
  • incus Version: 0.4
  • Linux gwy-rkurichi 5.15.0-91-generic #101-Ubuntu SMP Tue Nov 14 13:30:08 UTC 2023 x86_64 x86_64 x86_64 GNU/Linux

Addittional information:

incus info --show-log win11

Name: win11
Type: virtual-machine
Architecture: x86_64
Created: 2024/01/16 16:01 GMT


incus storage pool config

  size: 300GiB
  source: /var/lib/incus/disks/incus-storage-pool.img
description: ""
name: incus-storage-pool
driver: btrfs
- /1.0/images/c7d55d83e02ef093275736800f047796f539a6fcf08901f4fee29c9c3cb022e9
- /1.0/instances/test
- /1.0/instances/win11
- /1.0/profiles/default
status: Created
- none

Could any one help please

Can you show incus show --expanded win11?

I dont think there is incus show command

just errors out for me

incus show --expanded win11
Error: unknown command "show" for "incus"

Did you mean this?

However if you are looking for the config I ran incus config show win11 --expanded

architecture: x86_64
  limits.cpu: "4"
  limits.memory: 8GiB e3965112-368b-4ab5-8f86-4cea93578bda
  volatile.eth0.hwaddr: 00:16:3e:57:4d:ff
  volatile.uuid: e11a5f3f-d4b3-473f-9502-2c3643071593
  volatile.uuid.generation: e11a5f3f-d4b3-473f-9502-2c3643071593
  volatile.vsock_id: "3324189322"
    name: eth0
    network: incusbr0
    type: nic
    boot.priority: "10"
    source: /home/rkurichi/win11.lxd.iso
    type: disk
    path: /
    pool: incus-storage-pool
    type: disk
    path: /dev/tpm0
    type: tpm
ephemeral: false
- default
stateful: false
description: ""

Hmm, that’s an odd failure to be getting, it seems related to the ISO image file itself rather than the root disk too.

Can you try importing that ISO into incus itself rather than passing it in as a file?

You’d do that with:

incus storage volume import incus-storage-pool win11-install /home/rkurichi/win11.lxd.iso --type=iso
incus config device remove win11 install
incus config device add win11 install disk pool=incus-storage-pool source=win11-install

wow that worked @stgraber

Much appreciated

Thank you for you time :slight_smile: