Failed to start daemon. Storage pool not btrfs



I have been having issues with actually doing anything with the software. I am not able to run any lxc/d commands on a Ubuntu server 20.04 system.

I got this error:

lxc profile create bridged
Error: Get “http://unix.socket/1.0”: dial unix /var/snap/lxd/common/lxd/unix.soc ket: connect: connection refused

And started looking for solutions. I ran these commands, based on what I found.

newgrp lxd
sudo usermod -a -G lxd $(whoami)

Which didn’t work. And then i ran this command, with the following output.

sudo lxd --debug --group lxd

INFO[05-18|18:09:13] LXD 4.0.6 is starting in normal mode     path=/var/snap/lxd/common/lxd
INFO[05-18|18:09:13] Kernel uid/gid map:
INFO[05-18|18:09:13]  - u 0 0 4294967295
INFO[05-18|18:09:13]  - g 0 0 4294967295
INFO[05-18|18:09:13] Configured LXD uid/gid map:
INFO[05-18|18:09:13]  - u 0 1000000 1000000000
INFO[05-18|18:09:13]  - g 0 1000000 1000000000
INFO[05-18|18:09:13] Kernel features:
INFO[05-18|18:09:13]  - closing multiple file descriptors efficiently: no
INFO[05-18|18:09:13]  - netnsid-based network retrieval: yes
INFO[05-18|18:09:13]  - pidfds: yes
INFO[05-18|18:09:13]  - uevent injection: yes
INFO[05-18|18:09:13]  - seccomp listener: yes
INFO[05-18|18:09:13]  - seccomp listener continue syscalls: yes
INFO[05-18|18:09:13]  - seccomp listener add file descriptors: no
INFO[05-18|18:09:13]  - attach to namespaces via pidfds: no
INFO[05-18|18:09:13]  - safe native terminal allocation : yes
INFO[05-18|18:09:13]  - unprivileged file capabilities: yes
INFO[05-18|18:09:13]  - cgroup layout: hybrid
WARN[05-18|18:09:13]  - Couldn't find the CGroup blkio.weight, disk priority will be ignored
WARN[05-18|18:09:13]  - Couldn't find the CGroup memory swap accounting, swap limits will be ignored
INFO[05-18|18:09:13]  - shiftfs support: yes
INFO[05-18|18:09:13] Initializing local database
DBUG[05-18|18:09:13] Initializing database gateway
DBUG[05-18|18:09:13] Start database node                      id=1 address= role=voter
INFO[05-18|18:09:13] Starting /dev/lxd handler:
INFO[05-18|18:09:13]  - binding devlxd socket                 socket=/var/snap/lxd/common/lxd/devlxd/sock
INFO[05-18|18:09:13] REST API daemon:
INFO[05-18|18:09:13]  - binding Unix socket                   socket=/var/snap/lxd/common/lxd/unix.socket
INFO[05-18|18:09:13] Initializing global database
DBUG[05-18|18:09:13] Dqlite: attempt 0: server 1: connected
INFO[05-18|18:09:13] Firewall loaded driver "nftables"
INFO[05-18|18:09:13] Initializing storage pools
DBUG[05-18|18:09:13] Initializing and checking storage pool "default"
DBUG[05-18|18:09:13] Mount started                            driver=btrfs pool=default
DBUG[05-18|18:09:13] Mount finished                           driver=btrfs pool=default
EROR[05-18|18:09:13] Failed to start the daemon: Failed initializing storage pool "default": Source path '/var/snap/lxd/common/lxd/storage-pools/default' isn't btrfs
INFO[05-18|18:09:13] Starting shutdown sequence
INFO[05-18|18:09:13] Closing the database
INFO[05-18|18:09:13] Stop database gateway
INFO[05-18|18:09:14] Stopping REST API handler:
INFO[05-18|18:09:14]  - closing socket                        socket=/var/snap/lxd/common/lxd/unix.socket
INFO[05-18|18:09:14] Stopping /dev/lxd handler:
INFO[05-18|18:09:14]  - closing socket                        socket=/var/snap/lxd/common/lxd/devlxd/sock
INFO[05-18|18:09:14] Unmounting temporary filesystems
INFO[05-18|18:09:14] Done unmounting temporary filesystems
Error: Failed initializing storage pool "default": Source path '/var/snap/lxd/common/lxd/storage-pools/default' isn't btrfs

And when looking for that specific error, I didn’t find any solution that seemed to do the trick.
Any troubleshooting steps I might have missed, or a solution I didn’t find?

I ended up reinstalling this, completely. But if someone could point to what went wrong, that would be great. So it doesn’t happen again. It seems to run fine now, with no real changes compared to pre-reinstall

That error means that the BTRFS storage pool has a source property that is expected to be a BTRFS mounted BTRFS filesystem, but in this case its not.

I suspect when you had setup the storage pool it was mounted but on subsequent reboot it was not.