Failing to create container instance

I was trying to create a container instance today using images:alpine/3.19 and I got this error:

Error: Failed instance creation: Failed getting remote image info: Failed getting image: More than one match for the provided partial fingerprint "5112eb1849507214eb0f00052b891bb7e3c3722549c019870e2bfe7a1313fa0f"

I’m not sure what’s happening here. I tried creating a new cluster and was able to start the instance.

This is happening on my existing cluster. If anyone has any clue how to resolve this please let me know.

More details on this, I tried using the API to create container and it seems to work, but when I use the lxc client I get the above error.

Have a look at this,

Hi @simos yeah I’m aware of the phasing out of the image server.

It seems the problem is related to how LXD parses the image metadata from the images: server. This started to happen recently.

I’m using alpine images which should technically still be available until May

The solution has been found Fail instance creation due to fingerprint issue (LXD 5.0.3) - #16 by zacksiri - LXD - Ubuntu Community Hub